icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.58hongle.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

彩票公式 www.ag73.cc-信誉彩票app| www.747636.com-爱上彩票下载| www.848131.com-彩票818的真假| www.941787.com-湖北快三开结果| 500彩票www.50064r.com| www.7248.cc-彩虹短文阅读| www.41246.com-彩宝彩票电脑版| www.112678.cc-七乐彩查询中奖号码| www.230528.com-福利彩票包含快三吗| www.076969.com-玩快三正规网站| www.342212.com-大发快三微信群交流| www.838169.com-竞彩篮球技巧心得| www.950088.com-易赢彩票官网| 大赢家彩票网www.544096.com| www.530825.com-彩铅零基础画| www.636362.com-彩虹糖小豆机圣诞| www.720122.com-北京28彩票官网| www.112785.com-有云南快三么| www.199720.com-福建体彩官网走势图| www.818915.com-易彩云系统福利彩票| www.695651.com-足彩串关中奖规则| www.758716.com-彩票十选五网址| www.819944.com-快三和值012路图| www.874634.com-湖北体彩网官方网站| www.0858.xyz-彩票机器人投注| www.627028.com-500w彩票钟洁| www.121762.com-宁夏中卫福彩中心| www.221352.com-ha0123彩票-| www.308006.com-7彩彩票777-| www.678736.com-彩票网站制作费用| www.995016.com-快三哪里开奖最快| www.005069.com-体彩6十1中的玩法| www.126671.com-微信上可以买彩票吗| www.537976.com-国彩彩票怎么样| www.7724.vip-信彩网-| www.676129.com-五分赛车彩票| www.790452.com-赢家彩票注册| www.883502.com-福盈门彩票平台| www.295613.com-吉林快三摇奖系统| www.483825.com-彩票充值软件| www.247553.com-快三怎么分析大小| www.356202.com-彩雷王1688-| www.568482.com-重庆时时彩遗漏新浪| www.qq98.com-福彩的属性-| www.155809.com-好彩堂必中一肖| www.6720.vip-广东好彩36机选号| www.275632.com-安徽快三彩乐乐| www.362821.com-有多少人买过私彩| www.465464.com-稳赚不赔彩票秘诀| www.595788.com-聚鑫彩票平台黑| www.670690.com-重庆时时彩有几种| www.752922.com-335彩票下载安装| www.830937.com-网易彩票软件下载| www.938608.com-共赢福彩-| www.987117.com-立彩助手苹果版下载| www.qv6.cc-河北快三今日推荐号| www.049960.com-体彩试机号金码关注| www.012506.com-七星彩廉江高手论坛| www.314668.com-足球彩票规则及玩法| www.605521.com-彩晶膜-| www.013373.com-开心七星彩论坛交流| www.933333.cc-广东省彩票兑奖中心| www.94ky.com-万易彩票怎么样| www.4207.com-七彩教育网成绩查询| www.612934.com-彩票数字3开奖| www.736671.com-福彩3d菠萝魔图| www.819650.com-易中奖预测彩票准吗| www.896941.com-广西福利彩票下载| www.964810.com-二分时时彩全天人工| www.cai5503.com甘肃快三直选走势图| www.369705.com-彩票中五位数有奖吗| www.209938.com-大发快三的网站| www.27764.com-足彩主负什么意思| www.5703.me-易彩时时彩-| www.683059.com-彩票游戏网站排名| www.320161.com-湖北快三百宝彩| www.0976.org-后二时时彩技巧论坛| www.8537.xyz-彩票2元网怎么样| www.052786.com-826彩票下载安装| www.198785.com-吉林快三查询结好果| www.cai5670.com内蒙快三开奘结果| www.503337.com-彩票公司控制亚洲杯| www.648198.com-斯蒂芬彩票公式| www.556948.com-49c永利彩票注册| www.628009.com-12生肖彩票248| www.718098.com-周杰伦彩虹mv| www.846789.com-彩票小崔-| www.915889.com-湖北快三查-| www.973450.com-彩虹的美丽图片| www.df28.com-彩种是什么意思| www.tt72.com-全发国际买彩票| www.88212.com-彩民网是正规网站吗| www.15608.com-体彩高频走势图| www.34662.com-迷彩兔免费电影| www.10jk.com-体彩排五预测专家| www.557019.com-什么是vr彩票| www.258630.com-快三1.98赔率| www.82468.com-香港快三全天计划| www.087499.com-苹果吉林快三助手| www.182004.com-上海快三遗漏号| www.314017.com-14胜负彩开奖| www.384177.com-福利彩票诈骗案例| www.663992.com-今天打什么码七星彩| www.962784.com-星光彩票最新网站| www.295289.com-彩票送体验金| www.u10.bid-海南私彩预测| www.408186.com-纵横彩市大乐透| www.517226.com-中彩网老牌网站网址| www.513685.com-北京彩票新政| www.593048.com-彩虹电影在线直播| www.657547.com-利博彩票网站| www.831648.com-优选彩店下载| www.893090.com-休玉彩票-| www.003461.com-盈彩网是什么软件| www.36369.cc-网购福利彩票| www.716088.com-大发彩票可信吗| www.860370.com-牛彩彩票是真的吗| www.956683.com-错打彩票赔钱| PK彩票www.8499p.com| 聚福彩票www.50989f.com| www.107866.com-福彩出什么号| www.177700.com-快三助手手机版下载| www.734633.com-91彩神吧-| www.8179.biz-贵州快三垮度| www.38356.cc-红包彩票直播火火| www.269336.com-什么彩票软件好用| www.964986.com-微彩站app下载| 大赢家彩票平台www.376517.com| www.86383.cc-七星彩内部会员卡| www.570448.com-专业玩彩天天预测| www.638939.com-世界杯对体彩的影响| www.701551.com-五亿彩票网是哪里的| www.778565.com-体彩双色球开奖号| www.886499.com-爱购彩网站-| www.947840.com-竞彩彩票下载| www.998800.com-天津福运快三走势图| www.fl74.com-足彩胜负彩500| www.6146.me-河南商丘拓城彩礼| www.234278.com-福彩网络投注中心| www.346123.com-捷豹abc彩票系统| www.19lr.com-世彩堂靠谱吗| www.vs3.com-华人官方彩票登陆| www.134729.com-体彩七位数走势图表| www.233461.com-湖北快三号码统计| www.298783.com-中国手机彩票福彩网| www.030637.com-河北开乐彩-| www.087311.com-七星彩复式8个号码| www.272859.com-c303福彩-| www.020447.com-彩83软件下载| www.371355.com-网上购彩软件那个好| www.647531.com-体彩排列五免费资料| www.710507.com-刷彩单是什么情况| www.772808.com-时时彩买彩技巧| www.854745.com-广西快三改时间| www.907296.com-网上彩票app下载| www.971993.com-网络统一彩票骗局| 大赢家彩票网www.178993.com| www.54582.com-博胜彩票网投| www.an83.com-足球彩票过滤软件| www.560916.com-名人彩票是假的| www.698794.com-彩铅绘画技巧| www.21806.com-彩票被黑不给出款| www.66793.com-彩票3d怎么算中奖| www.056377.com-七星彩中奖查询器|